Scaling Issues in Checkpoint

Hi all, 

My name is Peter. I am new to this forum. I am a student as Michigan State University, where I work in a bioarchaeology lab. In the lab, we do 3D Photogrammetry of human bones. We build the models in Agisoft Photoscan using scale bars as a reference for size. The models in Photoscan build nicely, but we encounter problems when we import a finished model into Stratovan Checkpoint. Proportionally, the model looks fine, and there is no warping. The problem, however, arises in the scaling of the model. The program seems to have no concept of the actual size of the object in the bounding box. For example, we imported a complete skull into Checkpoint, and the bounding box dimensions read 1.4 mm x 1.5 mm x 1.8 mm. This is of course an impossibility because a human cranium is much larger than that. 

Has anyone encountered this problem before? I have talked to a few people, and someone has suggested that our issue is because of the file format that was exported from Photoscan and imported into Checkpoint. Apparently, the format we are using (PLY) does not contain unit/measurement data with it, which is why Checkpoint cannot tell the size of the object. This person has suggested that I try to make the export unit in Photscan to millimeters because this is the default unit in Checkpoint. I have tried with no success. Does anyone know of a way to do this? Or, alternatively, is there a different file format I can use that does contain unit/measurement data? Or perhaps adjust the settings in Checkpoint to make this work?

I know this was a lengthy post, so thanks for bearing with me. I just want to make sure whoever is reading has a decent understanding of my problem. 

Thank you so so much for your time. Any feedback is appreciated!





Pete, I apoligize for the delayed response. Yes, many surface based file formats do not include the units that the xyz coordinates are stored in. Yes, the best option would be to find in the original software how to specify the units in mm (we've found that most software tools seem to use mm as a default as do we).

Within Checkpoint, you can change the default specimen file interpretation from mm. This is done from the menu View | Specimen Units (per the file). This allows you to change the units of the file from mm to something else. You'll likely need to change this a couple times (to um or cm) until the displayed units along the bounding box or between two known points report dimensions that are accurate.

The View | Display Units option changes how the units are rendered on screen within Checkpoint.